Application portal is listing "sent" messages as "sending" (underlying delivery works)

Incident Report for Svix

Resolved

The issue has been working for the last few hours. Cached message statuses have also been fixed.
Posted Aug 15, 2023 - 17:44 UTC

Monitoring

Fix is deployed. It'll only fix it for new messages, fixing it for older ones (fixing the status cache there) will come in a bit.
Posted Aug 15, 2023 - 15:01 UTC

Identified

We got a few reports of an issue that some webhooks are showing as "sending" even though they successfully got sent. A fix is on the way, sorry about that.
It doesn't affect actual webhook delivery, it's just the UI that's affected.
Posted Aug 15, 2023 - 14:37 UTC
This incident affected: Application Portal.