[resolved] delayed delivery for some throttled messages (when endpoint throttling is configured) - normal delivery unaffected.

Incident Report for Svix

Resolved

Due to a race condition in the throttling code, some message may have been throttled for a much longer time than they were supposed to. The issue has been fixed and everything should be back in order.

No action needed.
Posted Jul 17, 2025 - 23:00 UTC